This project has moved. For the latest updates, please go here.

add in won't activate

Feb 28, 2013 at 11:11 AM
Edited Feb 28, 2013 at 11:12 AM
Sorry if this has been mentioned before.

I'm running Windows 7, Word 2007.

Downloaded the zip, extracted and installed for all users

No add in on the ribbon

Opened Word options (as admin)

Chem4word is there as inactive add in, clicked to manage COM type add in, chem4word is there, select the box and click okay but still nothing in ribbon even after re-start of word and/or pc

Not sure what to try now, the only thing I notice when in the manage COM section is that the Load Behaviour for chem4word is 'unloaded'

I have tried this on 2 machines with the same result - should I change the install to single user only?
Mar 1, 2013 at 5:59 AM
Edited Mar 1, 2013 at 6:04 AM
Hi Ajay,

Thank you for reporting the issue.

Please try out the below steps
  1. As you have Office 2007 installed on Windows 7, please ensure Office 2007 SP1 or SP2 is installed. You can download it from or
  2. Install Knowledge Base patch 976477 from this link:
  3. Then Run chem4word setup.exe
You should be able to get the Add-in loaded on the ribbon.

We are also releasing a new version of Chem4word add-in within a couple of days. you can download and start using it.

Mar 1, 2013 at 8:54 AM
Hi Prapthi,

Thanks for the reply, I appear to be using office with SP3, will this cause an issue?


Mar 1, 2013 at 8:57 AM
Should not be an issue. Install hotfix on top of it ( and you will get it worked.

Let me know if you face any issues.

Mar 1, 2013 at 9:28 AM
Hi again,

I tried it, the hotfix has an issue - 'The expected version was not found...'

Browsing for answers it appears to be a known problem with the hotfix that required MS Office to uninstalled and installed again.

I may wait for the new version and try that first :-)

Mar 1, 2013 at 9:34 AM
I shall mail you the hotfix which i have downloaded. Please give me your EmailID.

Mar 1, 2013 at 9:52 AM
Mar 1, 2013 at 10:08 AM
Sent to your inbox.

Mar 5, 2013 at 7:46 AM
Ajay- Did the solution work for you? Please let me know. Thanks
Mar 5, 2013 at 7:54 AM


Sorry no – same problem – hotfix doesn’t recognize the installed version of office.

Across 3 machines now – I can see from online discussions that re-installing office will do the job but I don’t fancy doing that at the moment.

Kind Regards,

Alex Holmes

From: prapthigowda [email removed]
Sent: 05 March 2013 08:46
Subject: Re: add in won't activate [chem4word:434841]

From: prapthigowda

Ajay- Did the solution work for you? Please let me know. Thanks

Mar 20, 2013 at 12:31 PM
I just downloaded this add in, and I had the same issue. First, make sure you extract the files. I ran it straigth from the zip accidently. So unzip them, and click on the 3rd file in there (setup.) This installs all the necessary info to put it on word. Before I did this, it would show up in my add ins, and I'd click the check box but the "load" didn't initialize (there was a line of this warning at the bottom of the "check" box.) Run the set up folder, THEN run the .exe file. It will load.

My question is, how do you get a chemical reaction after you've typed it in normal (sans subscripts) to convert to a proper formula??

Thanks, and hope this helps!
Mar 21, 2013 at 9:38 AM

Right click and click on Mark as chemistry Or select the text and click on Mark as chemistry button.

Once you mark it as chemistry you can view its formulas and 2D structure.