Add-in inactive

Mar 13, 2012 at 4:35 PM
Edited Mar 13, 2012 at 4:36 PM

The same issue has been around before, but none of the proposed solutions seemed to work for me.

After Installing using the setup.exe, there is no chemistry tab in the ribbon. When looking at the "Add-ins" it says there, that Chemistry Add-in for Word is inactive. Clicking on "go" and trying to activate it has no effect. The status says "not loaded".

System: XPSP3, Office 2007 SP3, System language is German (could that be a problem?)

I already tried:

- reinstalling .NET 4.0

- reinstalling Office 2007 PIA

Anybody has any idea?

Thanks for reading,

htho

Developer
Mar 14, 2012 at 6:24 AM
Edited Mar 14, 2012 at 6:35 AM

Hi,

Thank you for showing interest in Chemistry Add-in for Word.

I don't think, having a different system language is denying chem4word add-in to load into word.

In your case I think add-in encountering a problem while loading, this scenario is said to be add-in is soft disabled. When an add-in is soft disabled the entry of it will be displayed under "Inactive application add-ins" list within the View and manged Microst application add-ins window.

Please follow the steps given below to re-enable the soft disabled add-in ( for info:http://msdn.microsoft.com/en-us/library/ms268871.aspx):

1)      In the application, click the File tab (for Microsoft Office 2010) or the Microsoft Office Button (for the 2007 Microsoft Office system).

2)      Click the ApplicationName Options button.

3)      In the categories pane, click Add-ins.

4)      In the details pane, verify that the add-in appears in the Inactive Application Add-ins list. The Name column specifies the name of the assembly, and the Location column specifies the full path of the application manifest.

5)      In the Manage box, click COM Add-ins, and then click Go.

6)      In the COM Add-Ins dialog box, select the check box next to the disabled add-in.

7)      Click OK.

By now you would be able to see the Chemistry ribbon in the word.

If you still encounter with the same problem please make sure that Disable all applications add-ins option is unchecked in the Trust Center.

Steps to make sure the Disable all applications add-ins option is unchecked are:

1)      Click the Microsoft Office Button

2)      Click the ApplicationName Options button

3)      In the categories pane, click Trust Center

4)      Click Trust center settings button in the Microsoft Word Trust Center

5)      Click Add-ins in the category pane

6)      In the details pane, uncheck disable all applications add-ins option, If already checked
(I prefer you to uncheck all the options in the details pane).

7)      Click OK

8)      Follow the steps explained above to re-enable the soft disabled add-in (7 steps) and close and reopen the word.

 

In case the above attempt also fails. Please open the registry editor by

1)      Open a Run dialog

2)      Enter “regedit” command and Click OK. It will open the registry editor, now.

3)      Navigate to a path :HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\Chem4Word.AddIn ( if you have selected install for single user at the time of  chemistry add-in installation) or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins \ Chem4Word.AddIn (selected install for everyone).

4)      In the right hand side pane please verify that the value in the Data column for LoadBehavior key is set to 3 if not right click on LoadBehavior key select Modify. Enter value 3 in the text box under Value data. Click ok.

Now, create an environmental variable called VSTO_SUPPRESSDISPLAYALERTS and set its value as 0. Please follow the steps given in the site http://support.microsoft.com/kb/310519 for creating an environmental variable.

Now, close and reopen the word application if there are any exceptions at the time of add-in startup , it will open up a window with an exception message will be displayed in it. Please send this exception message to us if any and we will anylase it and let you know the steps to overcome the same.
 
I hope this will help you. Please let us know if you have any further queries.

Regards,
MSR Customer Support Team

 

 

Mar 16, 2012 at 9:08 AM

Thank you for your reply.

1. The add-in appears in the 'Inactive Application Add-ins' list. I can click the check box to activate it. After pressing ok and looking again, the add-in is still inactive.

2.  'Disable all applications add-ins' option was unchecked.

3. I changed the 'Load behavior' registry key. On my system it is under 'HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\Chemistry Add-in for Word'

4. I created the environment variable.

5. After starting Word: no change, no add-in and no exception message.

Developer
Mar 16, 2012 at 9:31 AM

Hi,

Do you have any other word add-ins installed on your system which explicitly loads .Net Framwork 1.1?

If any please disable all the add-ins  that explicitly loads the .Net Framework 1.1. This version of the .Net Framework work cannot  be loaded  in the same  application process with later version of  the .Net Framework . For more information see  http://msdn.microsoft.com/en-us/library/ee518876.aspx.

The other way to find out what is the problem with loading the add-in is by writing the errors to a log file.For that, create an another enviromental variable named VSTO_LOGALERTS and  set it to 1. The Visual studio office runtime  creates a log file  in the folder that contains the application manifest. The default name is <manefist name>.manifest.log. Please try this and check if there any error messages are logged to a log file and share the same with us.

Incase, above solution also doesn't work ,please uninstall the add-in and reinstall.

I hope the above information will help.

Thanks!
MSR Customer Support Team