This project has moved. For the latest updates, please go here.

Problem with "Chemistry Gallery"

Mar 17, 2012 at 7:31 PM
Edited Mar 18, 2012 at 8:56 AM

Hi everyone !

First, I'd like to thank the team for creating and updating this add-in, which is absolutly perfect for students like me and, I'm sure, for everyone near or far from the chemistry world.

My problem is that, when I click on the "Chemistry Gallery" command and I choose, for example, the Citric Acid structure, the program seems to load it, but nothing appears and Word bugs. Then I must close it with a Ctrl+Alt+Sup command. This occurs even if I've created a chemistry zone (right click, mark as chemistry).

A repair, with the Setup, doesn't change anything. Does someone have an idea to solve this problem ?

Thanks !

EDIT : I apologize, I forgot to say that I'm running on Windows 7 64-Bits, with Microsoft Office 2007.

Developer
Mar 19, 2012 at 4:32 AM
Edited Mar 19, 2012 at 4:34 AM

Hi,

Thank you for showing interest in Chemistry Add-in for Word.

Please make sure that you have all the neccessary prerequisites are intalled on your system for add-in to work properly.

Can you give us some details about version of .Net Framework and Visual Studio Tools for office installed on your machine. Also make your that you have Office2007PIA installed on your machine before install the add-in.

Are you getting any error message whlie you are encountering the problem if so please send us the that error message that help us to analyse the problem.

Do you have any other add-in installed on your machine if you have installed any please disable them and try using the Chemistry word Add-in. Some times having installed other add-in will deny add-ins to work properly.



If the above suggestions don't work . Please  try unistall the chemistry word add-in and re-install the same. This might solve your problem if add-in didn't install properly.

I hope the above information will help.Please let us know if you have any further queries.

Regards,
MSR Customer Support Team

 

 

 

 

 

Mar 19, 2012 at 6:39 PM

Hi,

Thanks for you answer and you help !

I uninstalled every plugin/add-in from Word as you said. Moreover, I downloaded the .NET Framework 4 (4.0.30319) and the Visual C++ 2010 (10.0.30319). And finally, I added Office2007PIA and uninstalled/installed again Chemistry Add-In for Word. It doesn't work.

In fact, when it occurs, Word just blocks and I must exit from it with a cut in the process. I cannot do anything in the program.

Thanks again for your help !

Regards.

Developer
Mar 20, 2012 at 4:25 AM

Hi,

Will you please follow the steps given below and let us know the status.

1) Open a Run dialog

2) Enter “regedit” command and Click OK. It will open the registry editor, now.

3) Navigate to a path :HKEY_CURRENT_USER\Software\Microsoft\Office\Word\Addins\Chem4Word.AddIn ( if you have selected install for single user at the time of chemistry add-in installation) or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins \ Chem4Word.AddIn (selected install for everyone).

4) In the right hand side pane please verify that the value in the Data column for LoadBehavior key is set to 3 if not right click on LoadBehavior key select Modify. Enter value 3 in the text box under Value data. Click ok.

Now, create an environmental variable called VSTO_SUPPRESSDISPLAYALERTS and set its value as 0. Please follow the steps given in the site http://support.microsoft.com/kb/310519 for creating an environmental variable.

Now, close all the instances of word and reopen. If there are any exceptions at the time of add-in startup , it will open up a window with an exception message will be displayed in it. Please send this exception message to us if any and we will anylase it and let you know the steps to overcome the same.

If the above attempt doesn't work please repair/reinstall your office 2007 and try reinstall the Chemistry word add-in. This would solve if there are any problem with the office application and hence it can load add-in without any issue.

I hope the above information will help.Please let us know if you have any further queries.

Regards,
MRC Customer Support Team

 

Mar 20, 2012 at 6:45 PM

Hi,

Thanks again for trying to help me. I did everything you said but it still don't work. Moreover, there is no exception message... What I'll do is just loading elements from the OPSIN or from many files I have (hopefully those 2 components work !)

If you can't solve this problem, don't worry, I will continue to support the program and recommand it to all of my contacts ;). Because I know that machines sometimes work, sometimes not, and it is not your fault at all :)

Best reguards guys, keep up the good job ! And thanks again for the help !

Developer
Mar 21, 2012 at 4:57 AM
Edited Mar 21, 2012 at 5:01 AM

Hi,

Thank you very much for supporting & recommending the chem4word add-in product.

I also have made an attempt to reproduce the issue with the same machine configuration as you have provided. But , I couldn't reproduce this issue on our machine, this features are working fine.

However, we have got one more way to find out exceptions/errors message which causes the problems. For that you need to  log the error messages to a log file. The same can be achieved by creating an enviromental variable named VSTO_LOGALERTS and set it to 1. The Visual studio office runtime creates a log file in the folder that contains the application manifest (Installation folder). The default name is <manefist name>.manifest.log (Chem4Word.AddIn.dll.manifest.log). If you find any error messages with the log file please share it with us that will help us to figure out the problem.


Regards,
MRC Customer Support Team

Mar 21, 2012 at 4:35 PM
Edited Mar 21, 2012 at 6:18 PM

Hi,

Thanks again for your help. I created the variable, no error message appears then I uploaded the whole file ( http://www.mediafire.com/?mh5hnla02rk8l94 ) so you can see it ! Hope it will help...

Best regards.

Developer
Mar 22, 2012 at 4:07 AM

Hi,

I have seen the file you have uploaded. It is a manifest file what you have uploaded, not the log file. The log file name will be Chem4Word.AddIn.dll.manifest.log (.log extenstion). If you don't find that file means that there no error messages/exceptions in the application. Without that it will be bit difficult to figure out what is causing problem.

Regards,
MRC Customer Support Team

Mar 22, 2012 at 6:08 AM

Hi,

Sorry for uploading the wrong file. I can't find the log file, it means that there is no error for Word.....

Thanks again for this help, even if it does not work, it was a pleasure to see that the team is always ok to help us. Thanks a lot !

Best regards

Developer
Mar 22, 2012 at 6:54 AM
Edited Mar 22, 2012 at 11:29 AM

Hi,

Shall we have a live meeting call with you and let us  investigate what is happening on your system? Our working hours will be from 10:00 Am to 6:00PM IST, from Monday to Friday.

 If you can join us by a call please let us know your convinient timings.

Also let us know your mail id as a point of contact. We will send a meeting request to your mail id.

Regards,
MRC Customer Support Team

Mar 25, 2012 at 12:29 PM

Hi,

Sorry, but I'm at school from 8:00 Am to 7:00 Pm so it will be hard to find a slot... Moreover I don't want to disturb you just for such a little problem.

I finally have an idea which solves the problem : because I have this problem only with this module ("Chemistry Gallery") of 6 molecules, I just have to load those molecules from the OPSIN website using the module "Load From". And it works perfectly :)

Thanks again for this dedicated help !

Best reguards to the whole team.

Developer
Mar 26, 2012 at 7:33 AM

Thanks wocker,Please feel free to reach us whenever you need our help.

Regards,
MRC Customer Support Team